]> Pileus Git - ~andy/sunrise/blob - app-dicts/words-bin/words-bin-1.97.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / app-dicts / words-bin / words-bin-1.97.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 MY_P="${P/-bin}Ed"
8
9 DESCRIPTION="Latin--English dictionary."
10 HOMEPAGE="http://users.erols.com/whitaker/words.htm"
11 SRC_URI="http://atrey.karlin.mff.cuni.cz/~sanda/mirror/${MY_P}-linux.tar.gz"
12
13 SLOT="0"
14 LICENSE="words"
15 KEYWORDS="~amd64 ~x86"
16
17 IUSE=""
18 DEPEND=""
19 RDEPEND=""
20
21 S="${WORKDIR}/${MY_P}"
22
23 src_unpack(){
24         unpack ${A}
25         cd "${S}"
26         epatch "${FILESDIR}"/words_dir.patch
27 }
28
29 src_install() {
30         insinto /opt/${MY_P}
31         dodoc wordsdoc*
32         rm wordsdoc*
33         doins *
34         dosym /opt/${MY_P}/latin /usr/bin/latin
35         fperms 755 /opt/${MY_P}/{latin,words}
36 }
37
38 pkg_postinst() {
39         elog "Dictionary is launched through 'latin' command"
40 }