]> Pileus Git - ~andy/sunrise/blob - app-dicts/words-bin/words-bin-1.97-r1.ebuild
app-dicts/words-bin: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / app-dicts / words-bin / words-bin-1.97-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6
7 inherit eutils
8
9 MY_P="${P/-bin}Ed"
10
11 DESCRIPTION="Latin--English dictionary."
12 HOMEPAGE="http://users.erols.com/whitaker/words.htm"
13 SRC_URI="http://atrey.karlin.mff.cuni.cz/~sanda/mirror/${MY_P}-linux.tar.gz"
14
15 SLOT="0"
16 LICENSE="words"
17 KEYWORDS="~amd64 ~x86"
18
19 IUSE=""
20 DEPEND=""
21 RDEPEND=""
22
23 S="${WORKDIR}/${MY_P}"
24
25 src_prepare(){
26         epatch "${FILESDIR}"/words_dir.patch
27 }
28
29 src_install() {
30         insinto /opt/${MY_P}
31         dodoc wordsdoc*
32         rm wordsdoc*
33         doins *
34         dosym /opt/${MY_P}/latin /usr/bin/latin
35         fperms 755 /opt/${MY_P}/{latin,words}
36 }
37
38 pkg_postinst() {
39         elog "Dictionary is launched through 'latin' command"
40 }