]> Pileus Git - ~andy/sunrise/blob - app-crypt/mypasswordsafe/mypasswordsafe-20060326.ebuild
Minor QA fixes
[~andy/sunrise] / app-crypt / mypasswordsafe / mypasswordsafe-20060326.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils qt3 toolchain-funcs
6
7 MY_PN="MyPasswordSafe"
8 DESCRIPTION="MyPasswordSafe is a password manager compatible with Password Safe."
9 HOMEPAGE="http://www.semanticgap.com/myps/"
10 SRC_URI="http://www.semanticgap.com/myps/release/${MY_PN}-${PV}.src.tgz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~x86"
15 IUSE=""
16
17 DEPEND="$(qt_min_version 3.3)"
18 RDEPEND="${DEPEND}"
19
20 S="${WORKDIR}/${MY_PN}-${PV}"
21
22 src_unpack() {
23         unpack ${A}
24         cd ${S}
25         epatch "${FILESDIR}/${PF}-gentoo.patch" || die "patch failed"
26 }
27
28 src_compile() {
29         emake CXX=$(tc-getCXX) PREFIX="/usr" all || die "failed to compile"
30 }
31
32 src_install() {
33         emake PREFIX="${D}/usr" install || die "install failed"
34 }