]> Pileus Git - ~andy/sunrise/blob - app-cdr/mirage2iso/mirage2iso-0.3.ebuild
2c7463525270dc5b5f81579dd2dd26340c2fc957
[~andy/sunrise] / app-cdr / mirage2iso / mirage2iso-0.3.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 inherit toolchain-funcs
8
9 DESCRIPTION="CD/DVD image converter using libmirage"
10 HOMEPAGE="http://qwpx.net/~mgorny/mirage2iso/"
11 SRC_URI="http://qwpx.net/~mgorny/${PN}/${P}.tar.bz2
12         test? ( http://qwpx.net/~mgorny/${PN}/${P}-tests.tar.xz )"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="pinentry test"
18
19 COMMON_DEPEND="dev-libs/libmirage
20         pinentry? ( dev-libs/libassuan )"
21 DEPEND="${COMMON_DEPEND}
22         test? ( app-arch/xz-utils )"
23 RDEPEND="${COMMON_DEPEND}
24         pinentry? ( app-crypt/pinentry )"
25
26 src_configure() {
27         tc-export CC
28         # we have to explicitly pass --bindir to workaround bugs in configure script
29         # (EPREFIX in parent environment causes confusion), fixed in r115
30         econf \
31                 --bindir="${EPREFIX}"/usr/bin \
32                 $(use_with pinentry assuan)
33 }
34
35 src_install() {
36         emake DESTDIR="${D}" install || die 'install failed'
37
38         dodoc NEWS README || die 'dodoc failed'
39 }