]> Pileus Git - ~andy/sunrise/blob - app-backup/rdup/rdup-1.1.5.ebuild
app-backup/rdup: version bump
[~andy/sunrise] / app-backup / rdup / rdup-1.1.5.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 DESCRIPTION="Generate a file list suitable for full or incremental backups"
8 HOMEPAGE="http://www.miek.nl/projects/rdup"
9 SRC_URI="http://www.miek.nl/projects/${PN}/${P}.tar.bz2"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="debug"
15
16 RDEPEND="app-arch/libarchive
17         dev-libs/glib
18         dev-libs/libpcre
19         dev-libs/nettle"
20 DEPEND="${RDEPEND}
21         test? ( dev-util/dejagnu )"
22
23 src_configure() {
24         econf $(use_enable debug)
25 }
26
27 src_test() {
28         if use debug; then
29                 ewarn "Test phase skipped, as it is known to fail with USE=\"debug\"."
30         else
31                 default_src_test
32         fi
33 }
34
35 src_install() {
36         emake DESTDIR="${D}" install || die "emake install failed"
37
38         dodoc AUTHORS ChangeLog README RELEASE-NOTES-1.1 || die "dodoc failed"
39 }