]> Pileus Git - ~andy/sunrise/blob - app-backup/rdup/rdup-1.0.2.ebuild
app-backup/rdup: version bump
[~andy/sunrise] / app-backup / rdup / rdup-1.0.2.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="The only backup program that doesn't make backups"
6 HOMEPAGE="http://www.miek.nl/projects/rdup"
7 SRC_URI="http://www.miek.nl/projects/${PN}/${P}.tar.bz2"
8 LICENSE="GPL-3"
9
10 SLOT="0"
11 KEYWORDS="~amd64 ~x86"
12 IUSE="test"
13
14 RDEPEND="app-arch/libarchive
15         dev-libs/glib
16         dev-libs/libpcre
17         dev-libs/nettle"
18 DEPEND="${RDEPEND}
19         test? ( dev-util/dejagnu )"
20
21 pkg_setup() {
22         # warning to upgraders
23         if has_version ${CATEGORY}/${PN}; then
24                 ewarn "In rdup 1.0.2, the rdup-simple script is moved from /usr/lib[64]/rdup to /usr/bin"
25                 ewarn "Please be sure to update your scripts or crontabs accordingly."
26         fi
27 }
28
29 src_compile() {
30         econf
31         emake || die "emake failed"
32 }
33
34 src_install() {
35         emake DESTDIR="${D}" install || die "emake install failed"
36
37         dodoc AUTHORS ChangeLog DESIGN README || die "dodoc failed"
38 }