]> Pileus Git - ~andy/sunrise/blob - app-backup/darbackup/darbackup-0.7.27.ebuild
sunrise/app-portage/elog-list/elog-list-0.0.6.ebuild: change headers to make repoman...
[~andy/sunrise] / app-backup / darbackup / darbackup-0.7.27.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils subversion
6
7 ESVN_REPO_URI="https://faracvs.cs.uni-magdeburg.de/svn/christsc/${PN}/${PN}/branches/${PV}"
8
9 DESCRIPTION="a wrapper script for creating backups using dar"
10 HOMEPAGE="https://faracvs.cs.uni-magdeburg.de/projects/christsc-darbackup/"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND=">=app-backup/dar-2.2.6
18         || ( dev-util/bdelta dev-util/xdelta )
19         net-misc/openssh"
20
21 pkg_setup() {
22         if ! built_with_use -o app-backup/dar dar32 dar64; then
23                 die 'You must have either dar32 or dar64 useflags for app-backup/dar enabled.'
24         fi
25
26         enewgroup backup
27 }
28
29 src_install() {
30         dobin darbackup
31         doman darbackup.1
32 }