]> Pileus Git - ~andy/sunrise/blob - app-arch/paq8l/paq8l-20070308.ebuild
app-admin/noobjuice-viewer: Fix qt deps, EAPI bump
[~andy/sunrise] / app-arch / paq8l / paq8l-20070308.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="Open source file compressor and archiver"
8 HOMEPAGE="http://www.cs.fit.edu/~mmahoney/compression"
9 SRC_URI="http://www.cs.fit.edu/~mmahoney/compression/${PN}.zip"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="app-arch/unzip"
17 RDEPEND=""
18
19 S=${WORKDIR}/${PN}
20
21 src_compile() {
22         $( tc-getCXX ) ${CXXFLAGS} -DNOASM -DUNIX ${PN}.cpp -o ${PN} || die "compile failed"
23 }
24
25 src_install() {
26         dobin ${PN} || die "dobin failed"
27         dodoc readme.txt || die "dodoc failed"
28 }