]> Pileus Git - ~andy/sunrise/blob - app-antivirus/xfprot/xfprot-1.18.ebuild
9dacd53112cd1c5ec4bb5a4d931622dde22358c4
[~andy/sunrise] / app-antivirus / xfprot / xfprot-1.18.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="A graphical frontend to the F-Prot Antivirus(TM) for Linux"
8 HOMEPAGE="http://web.tiscali.it/sharp/xfprot/"
9 SRC_URI="http://web.tiscali.it/sharp/xfprot/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14
15 IUSE_LINGUAS="linguas_de linguas_en linguas_es linguas_fr linguas_it linguas_pl linguas_pt_BR"
16 IUSE="${IUSE_LINGUAS} debug"
17
18 DEPEND=">=x11-libs/gtk+-2.4
19         >=app-antivirus/f-prot-4.6.0-r2"
20 RDEPEND="${DEPEND}"
21
22 pkg_setup() {
23         einfo "Please, set your LINGUAS to exactly ONE of the supported values."
24         einfo "This application cannot support multiple languages at the same time (yet)."
25 }
26
27 src_compile() {
28         local myconf=
29         use linguas_de && myconf="${myconf} --with-lang=de_DE"
30         use linguas_en && myconf="${myconf} --with-lang=en_GB"
31         use linguas_es && myconf="${myconf} --with-lang=es_ES"
32         use linguas_fr && myconf="${myconf} --with-lang=fr_FR"
33         use linguas_it && myconf="${myconf} --with-lang=it_IT"
34         use linguas_pl && myconf="${myconf} --with-lang=pl_PL"
35         use linguas_pt_BR && myconf="${myconf} --with-lang=pt_BR"
36
37         if [[ -z ${myconf} ]] ; then
38                 einfo "You didn't select any language, defaulting to English."
39                 einfo "If you want something else, set LINGUAS accordingly."
40                 epause 3
41                 myconf="--with-lang=en_GB"
42         fi
43
44         # not using econf because script does not like --prefix=/usr
45         ./configure \
46         --autodetect \
47         --with-install-dir="${D}/usr" \
48         ${myconf} \
49         $(use_with debug) || die "configure failed"
50         emake || die "emake failed"
51 }
52
53 src_install() {
54         # install manually, make install produces stupid directory structure
55         newbin ${S}/xfprot-gtk xfprot
56
57         # Install the icons
58         insinto /usr/share/pixmaps
59         newins icons/antivirus-32x32.png xfprot.png
60         for res in 32x32 48x48 64x64 128x128 ; do
61                 insinto /usr/share/icons/hicolor/${res}/apps/
62                 newins icons/antivirus-${res}.png xfprot.png
63         done
64         make_desktop_entry ${PN} "XFProt (F-Prot AV GUI)" ${PN}.png "Security;System;GTK"
65
66         dodoc Changelog README eicar.com.txt
67 }