]> Pileus Git - ~andy/sunrise/blob - app-antivirus/panda/panda-9.00.00.ebuild
3b0ac0c87a7872be5d1804d42707ac5b35438a93
[~andy/sunrise] / app-antivirus / panda / panda-9.00.00.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Panda Antivirus for Linux"
6 HOMEPAGE="http://www.pandasoftware.com/download/linux/linux.asp"
7 SRC_URI="http://shareware.pandasoftware.com/shareware/pavcl_linux.tgz"
8
9 SLOT="0"
10 LICENSE="Panda-Freeware"
11 KEYWORDS="~x86"
12 IUSE=""
13
14 DEPEND=""
15 RDEPEND=""
16 PROVIDE="virtual/antivirus"
17
18 RESTRICT="mirror strip"
19 QA_TEXTRELS_x86="opt/pavcl/usr/lib/libPsk*.so.*"
20 S="${WORKDIR}"
21
22 src_install() {
23         cp -r . "${D}"
24
25         dodir /etc/env.d
26         echo "PATH=\"/opt/pavcl/usr/bin\"" >> "${D}"/etc/env.d/90panda
27         echo "MANPATH=\"/opt/pavcl/usr/man\"" >> "${D}"/etc/env.d/90panda
28 }
29
30 pkg_postinst() {
31         elog "See \"man pavcl\" for usage instructions."
32         elog
33         elog "Updated virus definitions are not available for free."
34         elog "You need a username and password to download them"
35         elog "from http://acs.pandasoftware.com/software/basevirus/"
36 }
37
38 pkg_prerm() {
39         einfo "Removing stale logdir..."
40         [[ -d "${ROOT}/opt/pavcl/var/log/panda" ]] && rm -rf "${ROOT}/opt/pavcl/var/log/panda"
41 }