]> Pileus Git - ~andy/sunrise/blob - app-antivirus/clamtk/clamtk-4.35.ebuild
media-sound/ abcmidi: moved to gx86
[~andy/sunrise] / app-antivirus / clamtk / clamtk-4.35.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils perl-module
8
9 DESCRIPTION="A frontend for ClamAV using Gtk2-perl"
10 HOMEPAGE="http://clamtk.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="Artistic GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 LANGS="ar ast bg bs ca cs da de el en_GB es eu fi fo fr gl he hr hu id it ja ko lt ms nb nl nn pl pt pt_BR ro ru sk sl sv th tr ug uk zh_CN zh_TW"
18 IUSE="nls"
19 for i in ${LANGS}; do
20         IUSE="${IUSE} linguas_${i}"
21 done
22
23 DEPEND=""
24 RDEPEND=">=dev-perl/gtk2-perl-1.140
25         dev-perl/File-Find-Rule
26         dev-perl/libwww-perl
27         dev-perl/Net-DNS
28         dev-perl/Date-Calc
29         dev-util/desktop-file-utils
30         >=app-antivirus/clamav-0.95
31         nls? ( dev-perl/Locale-gettext )
32         sys-fs/udev"
33
34 src_unpack() {
35         unpack ${A}
36         cd "${S}"
37         gunzip ${PN}.1.gz || die "gunzip failed"
38 }
39
40 src_install() {
41         dobin ${PN} || die "dobin failed"
42
43         doicon ${PN}.png || die "doicon failed"
44         domenu ${PN}.desktop || die "domenu failed"
45
46         dodoc CHANGES README || die "dodoc failed"
47         doman ${PN}.1 || die "doman failed"
48
49         # The custom Perl modules
50         perlinfo
51         insinto ${VENDOR_LIB}/ClamTk
52         doins lib/*.pm || die "doins failed"
53
54         if use nls ; then
55                 domo po/*.mo || die "domo failed"
56         fi
57 }