]> Pileus Git - ~andy/sunrise/blob - app-antivirus/clamtk/clamtk-4.22.ebuild
net-misc/freego: A small fix thanks to sedzimir and metadata.xml updated
[~andy/sunrise] / app-antivirus / clamtk / clamtk-4.22.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils perl-module
6
7 DESCRIPTION="A frontend for ClamAV using Gtk2-perl"
8 HOMEPAGE="http://clamtk.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="Artistic GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14
15 LANGS="ar bg cs da de el en_GB es fr gl he hr hu it ja ko ms nb nl nn pl pt_BR ro ru sk sl sv tr zh_CN"
16 IUSE="nls"
17 for i in ${LANGS}; do
18         IUSE="${IUSE} linguas_${i}"
19 done
20
21 DEPEND=""
22 RDEPEND=">=dev-perl/gtk2-perl-1.140
23         dev-perl/File-Find-Rule
24         dev-perl/libwww-perl
25         dev-perl/Net-DNS
26         dev-perl/Date-Calc
27         dev-util/desktop-file-utils
28         >=app-antivirus/clamav-0.90
29         nls? ( dev-perl/Locale-gettext )"
30
31 src_unpack() {
32         unpack ${A}
33         cd "${S}"
34         perlinfo
35         sed -i -e "s:'/usr/lib':'${VENDOR_LIB}':"  clamtk \
36                 || die "sed failed"
37         gunzip ${PN}.1.gz || die "gunzip failed"
38 }
39
40 src_install() {
41         dobin ${PN} || die "dobin failed"
42
43         doicon ${PN}.png || die "doicon failed"
44         domenu ${PN}.desktop || die "domenu failed"
45
46         dodoc CHANGES README || die "dodoc failed"
47         doman ${PN}.1 || die "doman failed"
48
49         # The custom Perl modules
50         perlinfo
51         insinto ${VENDOR_LIB}/ClamTk
52         doins lib/*.pm || die "doins failed"
53
54         if use nls ; then
55                 domo po/*.mo || die "domo failed"
56         fi
57 }