]> Pileus Git - ~andy/sunrise/blob - app-admin/reprepro/reprepro-4.12.3.ebuild
add missing die
[~andy/sunrise] / app-admin / reprepro / reprepro-4.12.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 inherit flag-o-matic
8
9 DESCRIPTION="Debian APT repository creator and maintainer application"
10 HOMEPAGE="http://packages.debian.org/reprepro"
11 SRC_URI="http://alioth.debian.org/frs/download.php/3732/${PN}_${PV}.orig.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="archive bzip2 gpgme"
17
18 DEPEND=">=sys-libs/db-4.3
19         sys-libs/zlib
20         gpgme? ( app-crypt/gpgme dev-libs/libgpg-error )
21         archive? ( app-arch/libarchive )"
22 RDEPEND="${DEPEND}"
23
24 src_configure() {
25         use gpgme && append-cppflags -I/usr/include/gpgme
26         econf \
27                 $(use_with gpgme libgpgme) \
28                 $(use_with archive libarchive) \
29                 $(use_with bzip2 libbz2)
30 }