]> Pileus Git - ~andy/sunrise/blob - app-admin/osinfo/osinfo-0.3.0_rc1.ebuild
cfdc59aef350dd95f8e11ef7cb61729e4fe52ba2
[~andy/sunrise] / app-admin / osinfo / osinfo-0.3.0_rc1.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="lists system information available to the OS"
6 HOMEPAGE="http://osinfo.berlios.de"
7 SRC_URI="ftp://ftp.berlios.de/pub/${PN}/${P}.tar.bz2"
8
9 S="${WORKDIR}/${PN}"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 #IUSE="devices hdd html tcp"
15 IUSE="" #no use flags until Makefile understands to drop a module
16
17 DEPEND=""
18 RDEPEND="sys-devel/bc
19                 || ( sys-apps/gawk sys-apps/mawk )
20                 dev-libs/libxslt
21                 sys-apps/lshw
22                 sys-apps/pciutils
23                 sys-apps/usbutils
24                 sys-apps/hdparm
25                 app-admin/hddtemp
26                 >=sys-apps/smartmontools-5.36
27                 || ( net-analyzer/netcat net-analyzer/netcat6 net-analyzer/gnu-netcat )"
28
29 src_install() {
30         dobin osinfo
31         doman man/osinfo.1
32         dodoc docs/*
33 }
34
35 pkg_postinst() {
36         elog
37         elog "Osinfo is still a beta application - you can help fix bugs by joining"
38         elog "the osinfo mailinglist: osinfo@lists.berlios.de"
39         elog
40 #       elog "Osinfo has some nice features that are not obvious at first:"
41 #       elog "-  Create an HTML document of the computers in your LAN"
42 #       elog "-  Run osinfo in daemon mode on a box with an Apache server."
43 #       elog "-  Send the xml sheet to the daemon with the --tcpsend option."
44 #       elog "These features are still incomplete and are not yet installed by the ebuild,"
45 #       elog "but you can help to improve them!"
46 #       elog
47 #       elog "You can freely add more modules to osinfo. Check the source"
48 #       elog "code inside the tarball. Thank you for interest."
49 #       elog
50 }