]> Pileus Git - ~andy/sunrise/blob - app-admin/noobjuice-viewer/noobjuice-viewer-0.3-r1.ebuild
app-admin/noobjuice-viewer: Fix qt deps, EAPI bump
[~andy/sunrise] / app-admin / noobjuice-viewer / noobjuice-viewer-0.3-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6
7 inherit qt4-r2
8
9 DESCRIPTION="Viewer for the NoobJuice plugin-based GUI for Gentoo system administration."
10 HOMEPAGE="http://bobshaffer.net/?page=project_noobjuice_viewer"
11 SRC_URI="http://bobshaffer.net/projects/files/${P}.tgz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="dev-qt/qtgui:4[qt3support]"
19 RDEPEND="${DEPEND}"
20 S="${WORKDIR}"/noobjuice
21
22 src_install() {
23         emake INSTALL_ROOT="${D}" install || die "emake install failed"
24         dohtml doc/* || die "unable to install documentation"
25 }