]> Pileus Git - ~andy/sunrise/blob - app-admin/noobjuice-gentoo/noobjuice-gentoo-0.3.ebuild
app-admin/ldapscripts: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / app-admin / noobjuice-gentoo / noobjuice-gentoo-0.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit multilib qt4-r2
8
9 DESCRIPTION="The Gentoo base system plugins for the NoobJuice system administration GUI"
10 HOMEPAGE="http://bobshaffer.net/?page=project_noobjuice_gentoo"
11 SRC_URI="http://bobshaffer.net/projects/files/${P}.tgz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="doc"
17
18 DEPEND="dev-qt/qtgui:4"
19 RDEPEND="${DEPEND}
20         app-admin/noobjuice-viewer
21         >=app-portage/eix-0.18.0
22         app-portage/gentoolkit
23         app-portage/layman
24         >=app-admin/eselect-1.2.3
25         x11-terms/xterm"
26
27 S="${WORKDIR}/noobjuice-gentoo"
28
29 src_install() {
30         insinto /usr/$(get_libdir)/noobjuice/plugins
31         doins libnoobjuice-gentoo.so || die "libnoobjuice-gentoo.so not found"
32         if use doc ; then
33                 dohtml doc/* || die "failed to install documentation"
34         fi
35 }