]> Pileus Git - ~andy/sunrise/blob - app-admin/log4tailer/log4tailer-3.0.ebuild
add missing die
[~andy/sunrise] / app-admin / log4tailer / log4tailer-3.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 PYTHON_DEPEND="2"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="3.*"
10
11 inherit distutils
12
13 DESCRIPTION="Advanced log tailer written in python"
14 HOMEPAGE="http://code.google.com/p/log4tailer/"
15 SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
16
17 LICENSE="GPL-3"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="test"
21
22 DEPEND="dev-python/setuptools
23         test? ( dev-python/mox
24                 dev-python/paramiko )"
25 RDEPEND=""
26
27 src_test() {
28         testing() {
29                 PYTHONPATH=. $(PYTHON) setup.py test
30         }
31         python_execute_function testing
32 }
33
34 src_install() {
35         distutils_src_install
36
37         insinto /etc
38         newins log4tailerconfig.txt log4tailer.conf || die "newins failed"
39 }