]> Pileus Git - ~andy/sunrise/blob - app-admin/ldapscripts/ldapscripts-1.5.ebuild
797c490764aa3e5a507d90540100788b4f6b606b
[~andy/sunrise] / app-admin / ldapscripts / ldapscripts-1.5.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Shell scripts to manage POSIX accounts in an LDAP."
6 HOMEPAGE="http://contribs.martymac.com/"
7 SRC_URI="http://contribs.martymac.com/${PN}/${P}.tgz"
8
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="~x86"
12 IUSE=""
13
14 DEPEND=""
15 RDEPEND="net-nds/openldap
16         dev-libs/uulib"
17
18 RUNTIMEDIR="/var/run/${PN}"
19 RUNTIMEFILE="runtime"
20 ETCDIR="/etc/${PN}"
21 ETCFILE="ldapscripts.conf"
22
23 src_unpack() {
24         unpack ${A}
25
26         # Prepare sources, as the install script would do it
27         cd "${S}"
28         sed -i.orig -e "s|^_RUNTIMEFILE=.*|_RUNTIMEFILE=\"${RUNTIMEDIR}/${RUNTIMEFILE}\"|g" bin/*
29         sed -i.orig -e "s|^_CONFIGFILE=.*|_CONFIGFILE=\"${ETCDIR}/${ETCFILE}\"|g" etc/*
30 }
31
32 src_install() {
33         dobin bin/*
34         doman man/man1/*
35
36         insinto "${RUNTIMEDIR}"
37         doins "etc/${RUNTIMEFILE}"
38
39         insinto "${ETCDIR}"
40         doins "etc/${ETCFILE}"
41
42         dodoc CHANGELOG README TODO VERSION
43 }