]> Pileus Git - ~andy/sunrise/blob - app-admin/ldapscripts/ldapscripts-1.5-r1.ebuild
app-admin/ldapscripts: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / app-admin / ldapscripts / ldapscripts-1.5-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6
7 inherit eutils
8
9 DESCRIPTION="Shell scripts to manage POSIX accounts in an LDAP."
10 HOMEPAGE="http://contribs.martymac.com/"
11 SRC_URI="http://contribs.martymac.com/${PN}/${P}.tgz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND=""
19 RDEPEND="net-nds/openldap
20         dev-libs/uulib"
21
22 RUNTIMEDIR="/var/run/${PN}"
23 RUNTIMEFILE="runtime"
24 ETCDIR="/etc/${PN}"
25 ETCFILE="ldapscripts.conf"
26
27 src_prepare() {
28         sed -i.orig -e "s|^_RUNTIMEFILE=.*|_RUNTIMEFILE=\"${RUNTIMEDIR}/${RUNTIMEFILE}\"|g" bin/*
29         sed -i.orig -e "s|^_CONFIGFILE=.*|_CONFIGFILE=\"${ETCDIR}/${ETCFILE}\"|g" etc/*
30 }
31
32 src_install() {
33         dobin bin/*
34         doman man/man1/*
35
36         insinto "${RUNTIMEDIR}"
37         doins "etc/${RUNTIMEFILE}"
38
39         insinto "${ETCDIR}"
40         doins "etc/${ETCFILE}"
41
42         dodoc CHANGELOG README TODO VERSION
43 }