]> Pileus Git - ~andy/sunrise/blob - app-admin/conkyforecast/conkyforecast-2.10.ebuild
app-text/mupdf moved to tree
[~andy/sunrise] / app-admin / conkyforecast / conkyforecast-2.10.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 PYTHON_DEPEND="2"
8
9 inherit distutils python
10
11 DESCRIPTION="Conky weather forecast script with support for language files"
12 HOMEPAGE="https://launchpad.net/~conkyhardcore"
13 SRC_URI="https://launchpad.net/~conkyhardcore/+archive/ppa/+files/${PN}_${PV}.tar.gz"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND="app-admin/conky"
21
22 S=${WORKDIR}/src
23
24 pkg_config() {
25         python_set_active_version 2
26         python_pkg_setup
27 }
28
29 src_prepare() {
30         sed -i -e "s:/usr/bin/python:$(PYTHON -a):" conkyForecast || die
31         distutils_src_prepare
32 }
33
34 pkg_postinst() {
35         elog "You have to define a partner id and registration code for "
36         elog "the weather.com xoap. You need to copy the template from"
37         elog "/usr/share/conkyforecast/conkyForecast.config into you account"
38         elog "as ~/.conkyForecast.config and edit the respective fields."
39         elog
40         elog "More details can be found in the README file."
41 }