]> Pileus Git - ~andy/sunrise/blob - app-accessibility/julius/julius-4.1.ebuild
app-accessibility/julius: New ebuild for julius, see bug #245475. Thanks to idl0r...
[~andy/sunrise] / app-accessibility / julius / julius-4.1.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=1
6
7 inherit eutils
8
9 DESCRIPTION="High-performance, two-pass large vocabulary continuous speech recognition"
10 HOMEPAGE="http://julius.sourceforge.jp/en_index.php"
11 SRC_URI="mirror://sourceforge.jp/${PN}/33146/${P}.tar.gz"
12
13 LICENSE="julius"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE="alsa gtk gzip sndfile zlib"
17
18 DEPEND=">=sys-libs/readline-4.1
19         sys-libs/glibc
20         alsa? ( media-libs/alsa-lib )
21         gtk? ( x11-libs/gtk+:1 )
22         gzip? ( app-arch/gzip )
23         sndfile? ( media-libs/libsndfile )
24         zlib? ( sys-libs/zlib )"
25
26 src_unpack() {
27         unpack ${A}
28         cd "${S}"
29         epatch "${FILESDIR}"/julius-4.1-makefile.patch
30         epatch "${FILESDIR}"/julius-4.1-newParam.patch
31         epatch "${FILESDIR}"/julius-4.1-mkfacrash.patch
32 }
33
34 src_install() {
35         emake DESTDIR="${D}" install || die
36 }