]> Pileus Git - ~andy/sunrise/blob - app-accessibility/julius/julius-4.1-r1.ebuild
fix changelogs
[~andy/sunrise] / app-accessibility / julius / julius-4.1-r1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6
7 inherit eutils
8
9 DESCRIPTION="High-performance, two-pass large vocabulary continuous speech recognition"
10 HOMEPAGE="http://julius.sourceforge.jp/en_index.php"
11 SRC_URI="mirror://sourceforge.jp/${PN}/33146/${P}.tar.gz"
12
13 LICENSE="julius"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 LANGS="ja"
19
20 for LNG in ${LANGS}; do
21         IUSE="${IUSE} linguas_${LNG}"
22 done
23
24 DEPEND=">=sys-libs/readline-4.1
25         media-libs/alsa-lib
26         media-libs/libsndfile
27         sys-libs/zlib"
28 RDEPEND=${DEPEND}
29
30 src_prepare() {
31         epatch "${FILESDIR}"/julius-4.1-makefile.patch
32         epatch "${FILESDIR}"/julius-4.1-newParam.patch
33         epatch "${FILESDIR}"/julius-4.1-mkfacrash.patch
34 }
35
36 src_install() {
37         emake DESTDIR="${D}" install || die "emake install failed"
38         dodoc 00readme.txt Release.txt || die
39
40         for LNG in ${LINGUAS}; do
41                 dodoc 00readme-${LNG}.txt Release-${LNG}.txt || die
42         done
43 }