]> Pileus Git - grits/blobdiff - src/plugins/Makefile.am
Revert "Switch from GtkGLExt to internal OpenGL handling"
[grits] / src / plugins / Makefile.am
index 0e54a577719a451bb310e1f5dcfcbedb7f979a5e..bcdac95a026252d3a6e1a5392811909f4905a4d7 100644 (file)
@@ -2,7 +2,7 @@ MAINTAINERCLEANFILES = Makefile.in
 
 AM_CFLAGS   = -Wall --std=gnu99 -I$(top_srcdir)/src
 AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
-AM_LDFLAGS  = -module -avoid-version -no-undefined
+AM_LDFLAGS  = -shared -module -avoid-version -Wl,--as-needed
 LIBS        = $(top_srcdir)/src/libgrits.la
 
 pluginsdir  = "$(libdir)/$(GRITS_SUBDIR)"
@@ -14,6 +14,10 @@ map_la_SOURCES      = map.c  map.h
 env_la_SOURCES      = env.c  env.h
 test_la_SOURCES     = test.c test.h
 
+if WIN32
+AM_LDFLAGS += -no-undefined
+endif
+
 noinst_LTLIBRARIES  = teapot.la
 teapot_la_SOURCES   = \
        $(top_srcdir)/examples/plugin/teapot.c \