]> Pileus Git - grits/blobdiff - src/plugins/Makefile.am
Remove optional GLUT dependencies
[grits] / src / plugins / Makefile.am
index 8e6f5f6eb0ef0a26f6fbe9ae80af79489b1ea670..9e8628c54e0558c3f96928424891930bd093d352 100644 (file)
@@ -1,10 +1,17 @@
 MAINTAINERCLEANFILES = Makefile.in
 
 AM_CFLAGS   = -Wall --std=gnu99 -I$(top_srcdir)/src
-AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
-AM_LDFLAGS  = -shared -module -avoid-version -Wl,--as-needed
+AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(GL_CFLAGS) $(SOUP_CFLAGS)
+AM_LDFLAGS  = -shared -module -avoid-version
 LIBS        = $(top_srcdir)/src/libgrits.la
 
+if SYS_WIN
+AM_LDFLAGS += -no-undefined
+endif
+if !SYS_MAC
+AM_LDFLAGS += -Wl,--as-needed
+endif
+
 pluginsdir  = "$(libdir)/$(GRITS_SUBDIR)"
 
 plugins_LTLIBRARIES = sat.la elev.la map.la env.la test.la
@@ -14,12 +21,8 @@ map_la_SOURCES      = map.c  map.h
 env_la_SOURCES      = env.c  env.h
 test_la_SOURCES     = test.c test.h
 
-if HAVE_GLUT
-noinst_LTLIBRARIES  = teapot.la
-teapot_la_SOURCES   = \
-       $(top_srcdir)/examples/plugin/teapot.c \
-       $(top_srcdir)/examples/plugin/teapot.h
-endif
+env_la_CPPFLAGS     = $(AM_CPPFLAGS)
+env_la_LDFLAGS      = $(AM_LDFLAGS)
 
 test:
        ( cd ../; make test )