]> Pileus Git - grits/blobdiff - src/plugins/Makefile.am
Add glut config check
[grits] / src / plugins / Makefile.am
index 390e7e30c2b2bafc8fc31073d52b96a1aa820304..8e6f5f6eb0ef0a26f6fbe9ae80af79489b1ea670 100644 (file)
@@ -2,22 +2,24 @@ MAINTAINERCLEANFILES = Makefile.in
 
 AM_CFLAGS   = -Wall --std=gnu99 -I$(top_srcdir)/src
 AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
-AM_LDFLAGS  = -module -avoid-version -no-undefined
-LIBS        = $(top_srcdir)/src/libgis.la
+AM_LDFLAGS  = -shared -module -avoid-version -Wl,--as-needed
+LIBS        = $(top_srcdir)/src/libgrits.la
 
-pluginsdir  = "$(libdir)/gis"
+pluginsdir  = "$(libdir)/$(GRITS_SUBDIR)"
 
-plugins_LTLIBRARIES = sat.la elev.la map.la env.la
+plugins_LTLIBRARIES = sat.la elev.la map.la env.la test.la
 sat_la_SOURCES      = sat.c  sat.h
 elev_la_SOURCES     = elev.c elev.h
 map_la_SOURCES      = map.c  map.h
 env_la_SOURCES      = env.c  env.h
-
-noinst_LTLIBRARIES  = teapot.la test.la
 test_la_SOURCES     = test.c test.h
+
+if HAVE_GLUT
+noinst_LTLIBRARIES  = teapot.la
 teapot_la_SOURCES   = \
-       $(top_srcdir)/examples/plugin/teapot.c
+       $(top_srcdir)/examples/plugin/teapot.c \
        $(top_srcdir)/examples/plugin/teapot.h
+endif
 
 test:
        ( cd ../; make test )