]> Pileus Git - grits/blobdiff - src/plugins/Makefile.am
Add glut config check
[grits] / src / plugins / Makefile.am
index 0e54a577719a451bb310e1f5dcfcbedb7f979a5e..8e6f5f6eb0ef0a26f6fbe9ae80af79489b1ea670 100644 (file)
@@ -2,7 +2,7 @@ MAINTAINERCLEANFILES = Makefile.in
 
 AM_CFLAGS   = -Wall --std=gnu99 -I$(top_srcdir)/src
 AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
-AM_LDFLAGS  = -module -avoid-version -no-undefined
+AM_LDFLAGS  = -shared -module -avoid-version -Wl,--as-needed
 LIBS        = $(top_srcdir)/src/libgrits.la
 
 pluginsdir  = "$(libdir)/$(GRITS_SUBDIR)"
@@ -14,10 +14,12 @@ map_la_SOURCES      = map.c  map.h
 env_la_SOURCES      = env.c  env.h
 test_la_SOURCES     = test.c test.h
 
+if HAVE_GLUT
 noinst_LTLIBRARIES  = teapot.la
 teapot_la_SOURCES   = \
        $(top_srcdir)/examples/plugin/teapot.c \
        $(top_srcdir)/examples/plugin/teapot.h
+endif
 
 test:
        ( cd ../; make test )