]> Pileus Git - grits/blobdiff - src/plugins/Makefile.am
Update compass plugin
[grits] / src / plugins / Makefile.am
index cf4551301c7907ec0f2206f4f1e6b530953b1d1a..7c087a13ddf15dc1953db3a56185e2febcfee2d4 100644 (file)
@@ -20,7 +20,6 @@ elev_la_SOURCES     = elev.c elev.h
 map_la_SOURCES      = map.c  map.h
 env_la_SOURCES      = env.c  env.h
 test_la_SOURCES     = test.c test.h
-env_la_LDFLAGS      = $(AM_LDFLAGS) -lglut
 
 if HAVE_GLUT
 noinst_LTLIBRARIES  = teapot.la
@@ -28,6 +27,8 @@ teapot_la_SOURCES   = \
        $(top_srcdir)/examples/plugin/teapot.c \
        $(top_srcdir)/examples/plugin/teapot.h
 teapot_la_LDFLAGS   = $(AM_LDFLAGS) -lglut -rpath $(libdir) # I hate you libtool
+env_la_CPPFLAGS     = $(AM_CPPFLAGS) -DHAVE_GLUT
+env_la_LDFLAGS      = $(AM_LDFLAGS) -lglut
 endif
 
 test: