]> Pileus Git - grits/blobdiff - src/Makefile.am
adding zooming
[grits] / src / Makefile.am
index 8611e504e5a6fb3a983abe66d2d5894fca81e617..fad1033ba25d59d4110d92276b9cfb4eebdcf179 100644 (file)
@@ -1,9 +1,11 @@
-AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
-AM_CFLAGS    = -Wall -Werror -Wno-unused --std=gnu99 
-AM_LDFLAGS   = -Wl,--export-dynamic
-bin_PROGRAMS = aweather wsr88ddec
+AM_LDFLAGS    = $(RSL_LIBS) $(GTK_LIBS)
+AM_CFLAGS     = -Wall -Werror -Wno-unused --std=gnu99 
+bin_PROGRAMS  = aweather wsr88ddec
+
+BUILT_SOURCES = marshal.c marshal.h
 
 aweather_SOURCES  = main.c \
+       marshal.c        marshal.h        \
        aweather-gui.c   aweather-gui.h   \
        aweather-view.c  aweather-view.h  \
        data.c           data.h           \
@@ -12,12 +14,15 @@ aweather_SOURCES  = main.c \
        plugin-radar-colormap.c           \
        plugin-ridge.c   plugin-ridge.h   \
        plugin-example.c plugin-example.h
-aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
+aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\"" 
 
 wsr88ddec         = wsr88ddec.c
 wsr88ddec_LDADD   = -lbz2
 
-# LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ 
+.list.c:
+       glib-genmarshal --prefix=aweather_cclosure_marshal --body   $< > $@
+.list.h:
+       glib-genmarshal --prefix=aweather_cclosure_marshal --header $< > $@
 
 test: all
        ./aweather