]> Pileus Git - grits/blobdiff - src/Makefile.am
old stuff
[grits] / src / Makefile.am
index 711939f66b6993f438402185f65d742acd96accd..f8c79e8a9b0ad3d64d41927b9550fb308c98d430 100644 (file)
@@ -1,2 +1,27 @@
-bin_PROGRAMS = aweather
-aweather_SOURCES = aweather.c
+SUBDIRS = gis plugins
+
+AM_CFLAGS   = -Wall --std=gnu99 
+AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
+AM_LDADD    = $(GLIB_LIBS) $(GTK_LIBS) $(SOUP_LIBS)
+
+bin_PROGRAMS = aweather wsr88ddec
+aweather_SOURCES  = main.c \
+       aweather-gui.c      aweather-gui.h \
+       aweather-location.c aweather-location.h
+aweather_CPPFLAGS = $(AM_CPPFLAGS) -DDATADIR="\"$(datadir)\""
+aweather_LDADD    = $(AM_LDADD) gis/libgis.la
+
+wsr88ddec       = wsr88ddec.c
+wsr88ddec_LDADD = -lbz2
+
+CLEANFILES = gmon.out valgrind.out
+MAINTAINERCLEANFILES = Makefile.in
+
+test: all
+       LD_LIBRARY_PATH=gis/.libs .libs/aweather -o -d 7 -s KVNX
+
+gdb: all
+       LD_LIBRARY_PATH=gis/.libs gdb .libs/aweather
+
+ddd: all
+       LD_LIBRARY_PATH=gis/.libs ddd .libs/aweather