]> Pileus Git - grits/blobdiff - src/Makefile.am
old stuff
[grits] / src / Makefile.am
index 705df0e19f69ca36897d94b0ad98b5c0246f2ffe..f8c79e8a9b0ad3d64d41927b9550fb308c98d430 100644 (file)
@@ -1,45 +1,27 @@
-AM_LDFLAGS    = $(RSL_LIBS) $(GTK_LIBS)
-AM_CFLAGS     = -Wall -Werror -Wno-unused --std=gnu99 
-bin_PROGRAMS  = aweather wsr88ddec
+SUBDIRS = gis plugins
 
-BUILT_SOURCES = marshal.c marshal.h
+AM_CFLAGS   = -Wall --std=gnu99 
+AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
+AM_LDADD    = $(GLIB_LIBS) $(GTK_LIBS) $(SOUP_LIBS)
 
+bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
-       marshal.c         marshal.h         \
-       aweather-gui.c    aweather-gui.h    \
-       aweather-view.c   aweather-view.h   \
-       aweather-plugin.c aweather-plugin.h \
-       data.c            data.h            \
-       location.c        location.h        \
-       plugin-radar.c    plugin-radar.h    \
-       plugin-radar-colormap.c             \
-       plugin-ridge.c    plugin-ridge.h    \
-       plugin-example.c  plugin-example.h
-aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\"" 
+       aweather-gui.c      aweather-gui.h \
+       aweather-location.c aweather-location.h
+aweather_CPPFLAGS = $(AM_CPPFLAGS) -DDATADIR="\"$(datadir)\""
+aweather_LDADD    = $(AM_LDADD) gis/libgis.la
 
-wsr88ddec         = wsr88ddec.c
-wsr88ddec_LDADD   = -lbz2
+wsr88ddec       = wsr88ddec.c
+wsr88ddec_LDADD = -lbz2
 
-.list.c:
-       glib-genmarshal --prefix=aweather_cclosure_marshal --body   $< > $@
-.list.h:
-       glib-genmarshal --prefix=aweather_cclosure_marshal --header $< > $@
+CLEANFILES = gmon.out valgrind.out
+MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       ./aweather
+       LD_LIBRARY_PATH=gis/.libs .libs/aweather -o -d 7 -s KVNX
 
 gdb: all
-       gdb ./aweather
+       LD_LIBRARY_PATH=gis/.libs gdb .libs/aweather
 
 ddd: all
-       ddd ./aweather
-
-memcheck:
-       G_SLICE=always-malloc                   \
-       G_DEBUG=gc-friendly,resident-modules    \
-       valgrind --leak-check=full              \
-                --leak-resolution=high         \
-                --num-callers=50               \
-                --suppressions=gtk.suppression \
-                ./aweather                     \
-       2> memcheck.log
+       LD_LIBRARY_PATH=gis/.libs ddd .libs/aweather