]> Pileus Git - grits/blobdiff - src/Makefile.am
old stuff
[grits] / src / Makefile.am
index 01465d4a8258279f2acc8510981fb6c36cb0b023..f8c79e8a9b0ad3d64d41927b9550fb308c98d430 100644 (file)
@@ -1,6 +1,6 @@
 SUBDIRS = gis plugins
 
-AM_CFLAGS   = -Wall -Werror -Wno-unused --std=gnu99 
+AM_CFLAGS   = -Wall --std=gnu99 
 AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
 AM_LDADD    = $(GLIB_LIBS) $(GTK_LIBS) $(SOUP_LIBS)
 
@@ -25,14 +25,3 @@ gdb: all
 
 ddd: all
        LD_LIBRARY_PATH=gis/.libs ddd .libs/aweather
-
-memcheck: all
-       LD_LIBRARY_PATH=gis/.libs               \
-       G_SLICE=always-malloc                   \
-       G_DEBUG=gc-friendly,resident-modules    \
-       valgrind --leak-check=full              \
-                --leak-resolution=high         \
-                --num-callers=100              \
-                --suppressions=gtk.suppression \
-                .libs/aweather                 \
-       2> valgrind.out