]> Pileus Git - grits/blobdiff - src/Makefile.am
Lots of work on libGIS
[grits] / src / Makefile.am
index 18976bc36dac8d84f8eb08932cbe2116f5459888..d5e5fac0cbc01dc8bc1e37d3966deca1e44d2eb7 100644 (file)
@@ -16,20 +16,21 @@ CLEANFILES = gmon.out valgrind.out
 MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       ./aweather -o -d 7 -s KVNX
+       LD_LIBRARY_PATH=gis/.libs .libs/aweather -o -d 7 -s KVNX
 
 gdb: all
-       gdb ./aweather
+       LD_LIBRARY_PATH=gis/.libs gdb .libs/aweather
 
 ddd: all
-       ddd ./aweather
+       LD_LIBRARY_PATH=gis/.libs ddd .libs/aweather
 
-memcheck:
+memcheck: all
+       LD_LIBRARY_PATH=gis/.libs               \
        G_SLICE=always-malloc                   \
        G_DEBUG=gc-friendly,resident-modules    \
        valgrind --leak-check=full              \
                 --leak-resolution=high         \
                 --num-callers=100              \
                 --suppressions=gtk.suppression \
-                ./aweather                     \
+                .libs/aweather                 \
        2> valgrind.out