]> Pileus Git - grits/blobdiff - src/Makefile.am
perspective + ridge
[grits] / src / Makefile.am
index 711939f66b6993f438402185f65d742acd96accd..c969493d750816406a4201c5a6d5800f1c29b0a6 100644 (file)
@@ -1,2 +1,11 @@
+AM_CPPFLAGS  = $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS)
+AM_CFLAGS    = -O3 -Wall -Werror --std=gnu99
+
 bin_PROGRAMS = aweather
-aweather_SOURCES = aweather.c
+
+aweather_SOURCES  = aweather.c opengl.c radar.c ridge.c example.c 
+aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
+
+test: all
+       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
+       ./aweather