]> Pileus Git - grits/blobdiff - src/Makefile.am
switching to glade
[grits] / src / Makefile.am
index 7605c8c084af7d72841f1a72497071fc9a201b72..ac915429897f12aab6ba1b2074d164268e02ae1b 100644 (file)
@@ -1,5 +1,18 @@
+AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
+AM_CFLAGS    = -O3 -Wall -Werror --std=gnu99 
+AM_LDFLAGS   = -Wl,--export-dynamic
 bin_PROGRAMS = aweather
 
-aweather_SOURCES  = aweather.c
-aweather_CPPFLAGS = @PACKAGE_CFLAGS@
-aweather_LDADD    = @PACKAGE_LIBS@
+aweather_SOURCES  = \
+       aweather.c       aweather.h       \
+       site.c           site.h           \
+       opengl.c         opengl.h         \
+       plugin-radar.c   plugin-radar.h   \
+       plugin-ridge.c   plugin-ridge.h   \
+       plugin-example.c plugin-example.h
+aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
+
+
+test: all
+       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
+       ./aweather