]> Pileus Git - grits/blobdiff - src/Makefile.am
adding own colormap
[grits] / src / Makefile.am
index cca3efd5515bd094c6034880c356b4c4bc49a2af..a47ed55150534704b6832b5d0216c29fd18ac903 100644 (file)
@@ -1,5 +1,29 @@
-bin_PROGRAMS = aweather
+AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
+AM_CFLAGS    = -Wall -Werror -Wno-unused --std=gnu99 
+AM_LDFLAGS   = -Wl,--export-dynamic
+bin_PROGRAMS = aweather wsr88ddec
 
-aweather_SOURCES  = aweather.c aweather.h cube.c cube.h
-aweather_CPPFLAGS = @PACKAGE_CFLAGS@
-aweather_LDADD    = @PACKAGE_LIBS@
+aweather_SOURCES  = main.c \
+       aweather-gui.c   aweather-gui.h   \
+       aweather-view.c  aweather-view.h  \
+       data.c           data.h           \
+       location.c       location.h       \
+       plugin-radar.c   plugin-radar.h   \
+       plugin-radar-colormap.c           \
+       plugin-ridge.c   plugin-ridge.h   \
+       plugin-example.c plugin-example.h
+aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
+
+wsr88ddec         = wsr88ddec.c
+wsr88ddec_LDADD   = -lbz2
+
+# LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ 
+
+test: all
+       ./aweather
+
+gdb: all
+       gdb ./aweather
+
+ddd: all
+       ddd ./aweather