]> Pileus Git - grits/blobdiff - src/Makefile.am
adding own colormap
[grits] / src / Makefile.am
index 4fecc9749f0f711389fd62b3aa79b4eab48e4d42..a47ed55150534704b6832b5d0216c29fd18ac903 100644 (file)
@@ -1,16 +1,29 @@
-AM_CPPFLAGS  = $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS)
-AM_CFLAGS    = -O3 -Wall -Werror --std=gnu99
+AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
+AM_CFLAGS    = -Wall -Werror -Wno-unused --std=gnu99 
+AM_LDFLAGS   = -Wl,--export-dynamic
+bin_PROGRAMS = aweather wsr88ddec
 
-bin_PROGRAMS = aweather
-
-aweather_SOURCES  =  \
-       aweather.c       aweather.h       \
-       opengl.c         opengl.h         \
+aweather_SOURCES  = main.c \
+       aweather-gui.c   aweather-gui.h   \
+       aweather-view.c  aweather-view.h  \
+       data.c           data.h           \
+       location.c       location.h       \
        plugin-radar.c   plugin-radar.h   \
+       plugin-radar-colormap.c           \
        plugin-ridge.c   plugin-ridge.h   \
        plugin-example.c plugin-example.h
 aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
 
+wsr88ddec         = wsr88ddec.c
+wsr88ddec_LDADD   = -lbz2
+
+# LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ 
+
 test: all
-       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
        ./aweather
+
+gdb: all
+       gdb ./aweather
+
+ddd: all
+       ddd ./aweather