]> Pileus Git - grits/blobdiff - src/Makefile.am
Reorganize BMNG and SRTM into plugins
[grits] / src / Makefile.am
index 673662290a27173d29e70f2b1464cefe5936b426..97ec6ba438d4c633dd5fbd05b57910cb08f2b9ab 100644 (file)
@@ -1,28 +1,76 @@
-AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
-AM_CFLAGS    = -Wall -Werror -Wno-unused --std=gnu99 
-AM_LDFLAGS   = -Wl,--export-dynamic
-bin_PROGRAMS = aweather wsr88ddec
-
-aweather_SOURCES  = main.c \
-       aweather-gui.c   aweather-gui.h   \
-       aweather-view.c  aweather-view.h  \
-       data.c           data.h           \
-       location.c       location.h       \
-       plugin-radar.c   plugin-radar.h   \
-       plugin-ridge.c   plugin-ridge.h   \
-       plugin-example.c plugin-example.h
-aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
-
-wsr88ddec         = wsr88ddec.c
-wsr88ddec_LDADD   = -lbz2
-
-# LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ 
+SUBDIRS = plugins
+
+AM_CFLAGS   = -Wall --std=gnu99 
+AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
+AM_LDADD    = $(GLIB_LIBS) $(GTK_LIBS) $(SOUP_LIBS)
+
+# Library
+BUILT_SOURCES = gis-marshal.c gis-marshal.h
+lib_LTLIBRARIES  = libgis.la
+gis_includedir = $(includedir)/gis
+gis_include_HEADERS = \
+       gis.h         \
+       gis-world.h   \
+       gis-view.h    \
+       gis-prefs.h   \
+       gis-opengl.h  \
+       gis-plugin.h  \
+       gis-data.h    \
+       gpqueue.h     \
+       roam.h        \
+       wms.h
+libgis_la_SOURCES = \
+       gis-world.c   gis-world.h   \
+       gis-view.c    gis-view.h    \
+       gis-prefs.c   gis-prefs.h   \
+       gis-opengl.c  gis-opengl.h  \
+       gis-plugin.c  gis-plugin.h  \
+       gis-marshal.c gis-marshal.h \
+       gis-data.c    gis-data.h    \
+       roam.c        roam.h        \
+       wms.c         wms.h         \
+       gpqueue.c     gpqueue.h
+libgis_la_CPPFLAGS = $(AM_CPPFLAGS) \
+       -DPKGDATADIR="\"$(datadir)/gis\"" -DPLUGINSDIR="\"$(libdir)/gis\""
+libgis_la_LIBADD = $(AM_LDADD)
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libgis.pc
+
+# Test programs
+bin_PROGRAMS = gis_test wms_test
+
+gis_test_SOURCES  = gis_test.c gis.h
+gis_test_LDFLAGS  = -static
+gis_test_LDADD    = $(AM_LDADD) libgis.la
+
+wms_test_SOURCES  = wms_test.c gis-world.c gis-world.h wms.c wms.h
+wms_test_LDADD    = $(AM_LDADD)
+
+MAINTAINERCLEANFILES = Makefile.in
+
+.list.c:
+       glib-genmarshal --prefix=gis_cclosure_marshal --body   $< > $@
+.list.h:
+       glib-genmarshal --prefix=gis_cclosure_marshal --header $< > $@
 
 test: all
-       ./aweather
+       ./gis_test
 
 gdb: all
-       gdb ./aweather
+       gdb ./gis_test
 
 ddd: all
-       ddd ./aweather
+       ddd ./gis_test
+
+memcheck: all
+       LD_LIBRARY_PATH=.libs                      \
+       G_SLICE=always-malloc                      \
+       G_DEBUG=gc-friendly,resident-modules       \
+       valgrind --track-origins=yes               \
+                --leak-check=full                 \
+                --leak-resolution=high            \
+                --num-callers=100                 \
+                --suppressions=../gtk.suppression \
+                .libs/gis_test                    \
+       2> valgrind.out