]> Pileus Git - grits/blobdiff - src/Makefile.am
Moving -Werror to gen.sh, improving wms_test
[grits] / src / Makefile.am
index 191dfab6a598328fe8046c16435456f7b6232e1f..96c7a6c3249a0eab2ce2a1852cf8669641d4e05e 100644 (file)
@@ -1,52 +1,38 @@
-SUBDIRS = plugins
+SUBDIRS = gis plugins
 
-AM_CFLAGS     = -Wall -Werror -Wno-unused --std=gnu99 
-bin_PROGRAMS  = aweather wsr88ddec
-
-BUILT_SOURCES = marshal.c marshal.h
+AM_CFLAGS   = -Wall --std=gnu99 
+AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
+AM_LDADD    = $(GLIB_LIBS) $(GTK_LIBS) $(SOUP_LIBS)
 
+bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
-       marshal.c         marshal.h         \
-       aweather-gui.c    aweather-gui.h    \
-       aweather-plugin.c aweather-plugin.h \
-       gis-opengl.c      gis-opengl.h      \
-       gis-view.c        gis-view.h        \
-       gis-world.c       gis-world.h       \
-       data.c            data.h            \
-       location.c        location.h        \
-       marching.c        marching.h
-aweather_CPPFLAGS = \
-       -DDATADIR="\"$(datadir)\"" \
-       -DPLUGINDIR="\"$(libdir)/aweather\"" \
-       $(RSL_CFLAGS) $(SOUP_CFLAGS) $(GLIB_CFLAGS) $(GTK_CFLAGS)
-aweather_LDADD    = $(RSL_LIBS) $(SOUP_LIBS) $(GLIB_LIBS) $(GTK_LIBS)
-
-wsr88ddec         = wsr88ddec.c
-wsr88ddec_LDADD   = -lbz2
+       aweather-gui.c      aweather-gui.h \
+       aweather-location.c aweather-location.h
+aweather_CPPFLAGS = $(AM_CPPFLAGS) -DDATADIR="\"$(datadir)\""
+aweather_LDADD    = $(AM_LDADD) gis/libgis.la
+
+wsr88ddec       = wsr88ddec.c
+wsr88ddec_LDADD = -lbz2
 
 CLEANFILES = gmon.out valgrind.out
 MAINTAINERCLEANFILES = Makefile.in
 
-.list.c:
-       glib-genmarshal --prefix=aweather_cclosure_marshal --body   $< > $@
-.list.h:
-       glib-genmarshal --prefix=aweather_cclosure_marshal --header $< > $@
-
 test: all
-       ./aweather -o -d 7 -s KVNX
+       LD_LIBRARY_PATH=gis/.libs .libs/aweather -o -d 7 -s KVNX
 
 gdb: all
-       gdb ./aweather
+       LD_LIBRARY_PATH=gis/.libs gdb .libs/aweather
 
 ddd: all
-       ddd ./aweather
+       LD_LIBRARY_PATH=gis/.libs ddd .libs/aweather
 
-memcheck:
+memcheck: all
+       LD_LIBRARY_PATH=gis/.libs               \
        G_SLICE=always-malloc                   \
        G_DEBUG=gc-friendly,resident-modules    \
        valgrind --leak-check=full              \
                 --leak-resolution=high         \
                 --num-callers=100              \
                 --suppressions=gtk.suppression \
-                ./aweather                     \
+                .libs/aweather                 \
        2> valgrind.out