]> Pileus Git - grits/blobdiff - src/Makefile.am
Moving -Werror to gen.sh, improving wms_test
[grits] / src / Makefile.am
index 0617f6aa2507dbb4e390dedfa7f7c656c64d1bb4..96c7a6c3249a0eab2ce2a1852cf8669641d4e05e 100644 (file)
@@ -1,23 +1,38 @@
-AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
-AM_CFLAGS    = -O3 -Wall -Werror --std=gnu99 
-AM_LDFLAGS   = -Wl,--export-dynamic
-bin_PROGRAMS = aweather
+SUBDIRS = gis plugins
 
+AM_CFLAGS   = -Wall --std=gnu99 
+AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
+AM_LDADD    = $(GLIB_LIBS) $(GTK_LIBS) $(SOUP_LIBS)
+
+bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
-       aweather-gui.c   aweather-gui.h   \
-       aweather-view.c  aweather-view.h  \
-       data.c           data.h           \
-       location.c       location.h       \
-       plugin-radar.c   plugin-radar.h   \
-       plugin-ridge.c   plugin-ridge.h   \
-       plugin-example.c plugin-example.h
-aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
+       aweather-gui.c      aweather-gui.h \
+       aweather-location.c aweather-location.h
+aweather_CPPFLAGS = $(AM_CPPFLAGS) -DDATADIR="\"$(datadir)\""
+aweather_LDADD    = $(AM_LDADD) gis/libgis.la
+
+wsr88ddec       = wsr88ddec.c
+wsr88ddec_LDADD = -lbz2
 
+CLEANFILES = gmon.out valgrind.out
+MAINTAINERCLEANFILES = Makefile.in
 
 test: all
-       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
-       ./aweather
+       LD_LIBRARY_PATH=gis/.libs .libs/aweather -o -d 7 -s KVNX
+
+gdb: all
+       LD_LIBRARY_PATH=gis/.libs gdb .libs/aweather
+
+ddd: all
+       LD_LIBRARY_PATH=gis/.libs ddd .libs/aweather
 
-debug: all
-       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
-       gdb ./aweather
+memcheck: all
+       LD_LIBRARY_PATH=gis/.libs               \
+       G_SLICE=always-malloc                   \
+       G_DEBUG=gc-friendly,resident-modules    \
+       valgrind --leak-check=full              \
+                --leak-resolution=high         \
+                --num-callers=100              \
+                --suppressions=gtk.suppression \
+                .libs/aweather                 \
+       2> valgrind.out