]> Pileus Git - grits/blobdiff - src/Makefile.am
adding rsl ebuild, gtk suppressions for valgrind
[grits] / src / Makefile.am
index c6b60557c5fcadae6a2f8e139d0dfd4c05c8e858..8611e504e5a6fb3a983abe66d2d5894fca81e617 100644 (file)
@@ -1,7 +1,39 @@
-AM_CPPFLAGS  = $(GTK_CFLAGS)
-AM_CFLAGS    = -Wall -Werror --std=gnu99
+AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
+AM_CFLAGS    = -Wall -Werror -Wno-unused --std=gnu99 
+AM_LDFLAGS   = -Wl,--export-dynamic
+bin_PROGRAMS = aweather wsr88ddec
 
-bin_PROGRAMS = aweather
+aweather_SOURCES  = main.c \
+       aweather-gui.c   aweather-gui.h   \
+       aweather-view.c  aweather-view.h  \
+       data.c           data.h           \
+       location.c       location.h       \
+       plugin-radar.c   plugin-radar.h   \
+       plugin-radar-colormap.c           \
+       plugin-ridge.c   plugin-ridge.h   \
+       plugin-example.c plugin-example.h
+aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
 
-aweather_SOURCES  = aweather.c opengl.c cube.c radar.c 
-aweather_LDADD    = $(GTK_LIBS) -lrsl
+wsr88ddec         = wsr88ddec.c
+wsr88ddec_LDADD   = -lbz2
+
+# LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ 
+
+test: all
+       ./aweather
+
+gdb: all
+       gdb ./aweather
+
+ddd: all
+       ddd ./aweather
+
+memcheck:
+       G_SLICE=always-malloc                   \
+       G_DEBUG=gc-friendly,resident-modules    \
+       valgrind --leak-check=full              \
+                --leak-resolution=high         \
+                --num-callers=50               \
+                --suppressions=gtk.suppression \
+                ./aweather                     \
+       2> memcheck.log