]> Pileus Git - grits/blobdiff - src/Makefile.am
fixing more memory leaks
[grits] / src / Makefile.am
index a47ed55150534704b6832b5d0216c29fd18ac903..8611e504e5a6fb3a983abe66d2d5894fca81e617 100644 (file)
@@ -27,3 +27,13 @@ gdb: all
 
 ddd: all
        ddd ./aweather
+
+memcheck:
+       G_SLICE=always-malloc                   \
+       G_DEBUG=gc-friendly,resident-modules    \
+       valgrind --leak-check=full              \
+                --leak-resolution=high         \
+                --num-callers=50               \
+                --suppressions=gtk.suppression \
+                ./aweather                     \
+       2> memcheck.log