]> Pileus Git - grits/blobdiff - src/Makefile.am
Example plugin in GObject plugin format
[grits] / src / Makefile.am
index 8611e504e5a6fb3a983abe66d2d5894fca81e617..705df0e19f69ca36897d94b0ad98b5c0246f2ffe 100644 (file)
@@ -1,23 +1,29 @@
-AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
-AM_CFLAGS    = -Wall -Werror -Wno-unused --std=gnu99 
-AM_LDFLAGS   = -Wl,--export-dynamic
-bin_PROGRAMS = aweather wsr88ddec
+AM_LDFLAGS    = $(RSL_LIBS) $(GTK_LIBS)
+AM_CFLAGS     = -Wall -Werror -Wno-unused --std=gnu99 
+bin_PROGRAMS  = aweather wsr88ddec
+
+BUILT_SOURCES = marshal.c marshal.h
 
 aweather_SOURCES  = main.c \
-       aweather-gui.c   aweather-gui.h   \
-       aweather-view.c  aweather-view.h  \
-       data.c           data.h           \
-       location.c       location.h       \
-       plugin-radar.c   plugin-radar.h   \
-       plugin-radar-colormap.c           \
-       plugin-ridge.c   plugin-ridge.h   \
-       plugin-example.c plugin-example.h
-aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
+       marshal.c         marshal.h         \
+       aweather-gui.c    aweather-gui.h    \
+       aweather-view.c   aweather-view.h   \
+       aweather-plugin.c aweather-plugin.h \
+       data.c            data.h            \
+       location.c        location.h        \
+       plugin-radar.c    plugin-radar.h    \
+       plugin-radar-colormap.c             \
+       plugin-ridge.c    plugin-ridge.h    \
+       plugin-example.c  plugin-example.h
+aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\"" 
 
 wsr88ddec         = wsr88ddec.c
 wsr88ddec_LDADD   = -lbz2
 
-# LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ 
+.list.c:
+       glib-genmarshal --prefix=aweather_cclosure_marshal --body   $< > $@
+.list.h:
+       glib-genmarshal --prefix=aweather_cclosure_marshal --header $< > $@
 
 test: all
        ./aweather