]> Pileus Git - grits/blobdiff - src/Makefile.am
Replacing GFile/GIO with libsoup
[grits] / src / Makefile.am
index d05c4fbbeac4f2801f5fc2121a485ca06330ac5d..645fbed0a6dff86e771f8ff4b96a167197bacaa7 100644 (file)
@@ -1,4 +1,3 @@
-AM_LDFLAGS    = $(RSL_LIBS) $(GTK_LIBS)
 AM_CFLAGS     = -Wall -Werror -Wno-unused --std=gnu99 
 bin_PROGRAMS  = aweather wsr88ddec
 
@@ -15,7 +14,9 @@ aweather_SOURCES  = main.c \
        plugin-radar-colormap.c             \
        plugin-ridge.c    plugin-ridge.h    \
        plugin-example.c  plugin-example.h
-aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\"" 
+aweather_CPPFLAGS = -DDATADIR="\"$(datadir)\"" \
+       $(RSL_CFLAGS) $(SOUP_CFLAGS) $(GLIB_CFLAGS) $(GTK_CFLAGS)
+aweather_LDADD    = $(RSL_LIBS) $(SOUP_LIBS) $(GLIB_LIBS) $(GTK_LIBS)
 
 wsr88ddec         = wsr88ddec.c
 wsr88ddec_LDADD   = -lbz2
@@ -29,7 +30,7 @@ MAINTAINERCLEANFILES = Makefile.in
        glib-genmarshal --prefix=aweather_cclosure_marshal --header $< > $@
 
 test: all
-       ./aweather
+       ./aweather -d 7
 
 gdb: all
        gdb ./aweather
@@ -42,7 +43,7 @@ memcheck:
        G_DEBUG=gc-friendly,resident-modules    \
        valgrind --leak-check=full              \
                 --leak-resolution=high         \
-                --num-callers=50               \
+                --num-callers=100              \
                 --suppressions=gtk.suppression \
                 ./aweather                     \
        2> valgrind.out