]> Pileus Git - grits/blobdiff - src/Makefile.am
site and time selection for both ridge and radar
[grits] / src / Makefile.am
index 89408488b632009e423162656474b8fa1dec62b6..46324714f4abb74d7f43185b7c245d1fedce25ae 100644 (file)
@@ -1,18 +1,26 @@
 AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
-AM_CFLAGS    = -O3 -Wall -Werror --std=gnu99 
+AM_CFLAGS    = -O3 -Wall -Werror -Wno-unused --std=gnu99 
 AM_LDFLAGS   = -Wl,--export-dynamic
-bin_PROGRAMS = aweather
+bin_PROGRAMS = aweather wsr88ddec
 
-aweather_SOURCES  = \
-       aweather.c       aweather.h       \
+aweather_SOURCES  = main.c \
+       aweather-gui.c   aweather-gui.h   \
+       aweather-view.c  aweather-view.h  \
+       data.c           data.h           \
        location.c       location.h       \
-       opengl.c         opengl.h         \
        plugin-radar.c   plugin-radar.h   \
        plugin-ridge.c   plugin-ridge.h   \
        plugin-example.c plugin-example.h
 aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
 
+wsr88ddec         = wsr88ddec.c
+wsr88ddec_LDADD   = -lbz2
+
 
 test: all
        LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
        ./aweather
+
+debug: all
+       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
+       gdb ./aweather