]> Pileus Git - grits/blobdiff - src/Makefile.am
Adding a prefs dialog (which needs a lot more work)
[grits] / src / Makefile.am
index 705df0e19f69ca36897d94b0ad98b5c0246f2ffe..191dfab6a598328fe8046c16435456f7b6232e1f 100644 (file)
@@ -1,4 +1,5 @@
-AM_LDFLAGS    = $(RSL_LIBS) $(GTK_LIBS)
+SUBDIRS = plugins
+
 AM_CFLAGS     = -Wall -Werror -Wno-unused --std=gnu99 
 bin_PROGRAMS  = aweather wsr88ddec
 
@@ -7,26 +8,32 @@ BUILT_SOURCES = marshal.c marshal.h
 aweather_SOURCES  = main.c \
        marshal.c         marshal.h         \
        aweather-gui.c    aweather-gui.h    \
-       aweather-view.c   aweather-view.h   \
        aweather-plugin.c aweather-plugin.h \
+       gis-opengl.c      gis-opengl.h      \
+       gis-view.c        gis-view.h        \
+       gis-world.c       gis-world.h       \
        data.c            data.h            \
        location.c        location.h        \
-       plugin-radar.c    plugin-radar.h    \
-       plugin-radar-colormap.c             \
-       plugin-ridge.c    plugin-ridge.h    \
-       plugin-example.c  plugin-example.h
-aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\"" 
+       marching.c        marching.h
+aweather_CPPFLAGS = \
+       -DDATADIR="\"$(datadir)\"" \
+       -DPLUGINDIR="\"$(libdir)/aweather\"" \
+       $(RSL_CFLAGS) $(SOUP_CFLAGS) $(GLIB_CFLAGS) $(GTK_CFLAGS)
+aweather_LDADD    = $(RSL_LIBS) $(SOUP_LIBS) $(GLIB_LIBS) $(GTK_LIBS)
 
 wsr88ddec         = wsr88ddec.c
 wsr88ddec_LDADD   = -lbz2
 
+CLEANFILES = gmon.out valgrind.out
+MAINTAINERCLEANFILES = Makefile.in
+
 .list.c:
        glib-genmarshal --prefix=aweather_cclosure_marshal --body   $< > $@
 .list.h:
        glib-genmarshal --prefix=aweather_cclosure_marshal --header $< > $@
 
 test: all
-       ./aweather
+       ./aweather -o -d 7 -s KVNX
 
 gdb: all
        gdb ./aweather
@@ -39,7 +46,7 @@ memcheck:
        G_DEBUG=gc-friendly,resident-modules    \
        valgrind --leak-check=full              \
                 --leak-resolution=high         \
-                --num-callers=50               \
+                --num-callers=100              \
                 --suppressions=gtk.suppression \
                 ./aweather                     \
-       2> memcheck.log
+       2> valgrind.out