]> Pileus Git - grits/blobdiff - src/Makefile.am
Adding a prefs dialog (which needs a lot more work)
[grits] / src / Makefile.am
index 620cdcb18f280288915bb1a3f8238f3c0343030d..191dfab6a598328fe8046c16435456f7b6232e1f 100644 (file)
@@ -1,3 +1,5 @@
+SUBDIRS = plugins
+
 AM_CFLAGS     = -Wall -Werror -Wno-unused --std=gnu99 
 bin_PROGRAMS  = aweather wsr88ddec
 
@@ -6,16 +8,16 @@ BUILT_SOURCES = marshal.c marshal.h
 aweather_SOURCES  = main.c \
        marshal.c         marshal.h         \
        aweather-gui.c    aweather-gui.h    \
-       aweather-view.c   aweather-view.h   \
        aweather-plugin.c aweather-plugin.h \
+       gis-opengl.c      gis-opengl.h      \
+       gis-view.c        gis-view.h        \
+       gis-world.c       gis-world.h       \
        data.c            data.h            \
        location.c        location.h        \
-       marching.c        marching.h        \
-       plugin-radar.c    plugin-radar.h    \
-       plugin-radar-colormap.c             \
-       plugin-ridge.c    plugin-ridge.h    \
-       plugin-example.c  plugin-example.h
-aweather_CPPFLAGS = -DDATADIR="\"$(datadir)\"" \
+       marching.c        marching.h
+aweather_CPPFLAGS = \
+       -DDATADIR="\"$(datadir)\"" \
+       -DPLUGINDIR="\"$(libdir)/aweather\"" \
        $(RSL_CFLAGS) $(SOUP_CFLAGS) $(GLIB_CFLAGS) $(GTK_CFLAGS)
 aweather_LDADD    = $(RSL_LIBS) $(SOUP_LIBS) $(GLIB_LIBS) $(GTK_LIBS)