]> Pileus Git - grits/blobdiff - src/Makefile.am
* Road plan (HACKING)
[grits] / src / Makefile.am
index a47ed55150534704b6832b5d0216c29fd18ac903..18b7fba1dc450c034846f94261f4dc103e13c73a 100644 (file)
@@ -1,6 +1,5 @@
-AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
+AM_LDFLAGS   = $(RSL_LIBS) $(GTK_LIBS)
 AM_CFLAGS    = -Wall -Werror -Wno-unused --std=gnu99 
-AM_LDFLAGS   = -Wl,--export-dynamic
 bin_PROGRAMS = aweather wsr88ddec
 
 aweather_SOURCES  = main.c \
@@ -12,7 +11,7 @@ aweather_SOURCES  = main.c \
        plugin-radar-colormap.c           \
        plugin-ridge.c   plugin-ridge.h   \
        plugin-example.c plugin-example.h
-aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
+aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\"" 
 
 wsr88ddec         = wsr88ddec.c
 wsr88ddec_LDADD   = -lbz2
@@ -27,3 +26,13 @@ gdb: all
 
 ddd: all
        ddd ./aweather
+
+memcheck:
+       G_SLICE=always-malloc                   \
+       G_DEBUG=gc-friendly,resident-modules    \
+       valgrind --leak-check=full              \
+                --leak-resolution=high         \
+                --num-callers=50               \
+                --suppressions=gtk.suppression \
+                ./aweather                     \
+       2> memcheck.log