]> Pileus Git - grits/blobdiff - src/Makefile.am
* Road plan (HACKING)
[grits] / src / Makefile.am
index 711939f66b6993f438402185f65d742acd96accd..18b7fba1dc450c034846f94261f4dc103e13c73a 100644 (file)
@@ -1,2 +1,38 @@
-bin_PROGRAMS = aweather
-aweather_SOURCES = aweather.c
+AM_LDFLAGS   = $(RSL_LIBS) $(GTK_LIBS)
+AM_CFLAGS    = -Wall -Werror -Wno-unused --std=gnu99 
+bin_PROGRAMS = aweather wsr88ddec
+
+aweather_SOURCES  = main.c \
+       aweather-gui.c   aweather-gui.h   \
+       aweather-view.c  aweather-view.h  \
+       data.c           data.h           \
+       location.c       location.h       \
+       plugin-radar.c   plugin-radar.h   \
+       plugin-radar-colormap.c           \
+       plugin-ridge.c   plugin-ridge.h   \
+       plugin-example.c plugin-example.h
+aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\"" 
+
+wsr88ddec         = wsr88ddec.c
+wsr88ddec_LDADD   = -lbz2
+
+# LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ 
+
+test: all
+       ./aweather
+
+gdb: all
+       gdb ./aweather
+
+ddd: all
+       ddd ./aweather
+
+memcheck:
+       G_SLICE=always-malloc                   \
+       G_DEBUG=gc-friendly,resident-modules    \
+       valgrind --leak-check=full              \
+                --leak-resolution=high         \
+                --num-callers=50               \
+                --suppressions=gtk.suppression \
+                ./aweather                     \
+       2> memcheck.log