]> Pileus Git - grits/blobdiff - src/Makefile.am
* Road plan (HACKING)
[grits] / src / Makefile.am
index 46a3cda65f2d9648753c80cbb6e838dad5415e07..18b7fba1dc450c034846f94261f4dc103e13c73a 100644 (file)
@@ -1,11 +1,38 @@
-AM_CPPFLAGS  = $(GTK_CFLAGS) -I/usr/local/trmm/GVBOX/include/
-AM_CFLAGS    = -O3 -Wall -Werror --std=gnu99
+AM_LDFLAGS   = $(RSL_LIBS) $(GTK_LIBS)
+AM_CFLAGS    = -Wall -Werror -Wno-unused --std=gnu99 
+bin_PROGRAMS = aweather wsr88ddec
 
-bin_PROGRAMS = aweather
+aweather_SOURCES  = main.c \
+       aweather-gui.c   aweather-gui.h   \
+       aweather-view.c  aweather-view.h  \
+       data.c           data.h           \
+       location.c       location.h       \
+       plugin-radar.c   plugin-radar.h   \
+       plugin-radar-colormap.c           \
+       plugin-ridge.c   plugin-ridge.h   \
+       plugin-example.c plugin-example.h
+aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\"" 
 
-aweather_SOURCES  = aweather.c opengl.c radar.c ridge.c example.c 
-aweather_LDADD    = $(GTK_LIBS) -L/usr/local/trmm/GVBOX/lib/ -lrsl
+wsr88ddec         = wsr88ddec.c
+wsr88ddec_LDADD   = -lbz2
+
+# LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ 
 
 test: all
-       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
        ./aweather
+
+gdb: all
+       gdb ./aweather
+
+ddd: all
+       ddd ./aweather
+
+memcheck:
+       G_SLICE=always-malloc                   \
+       G_DEBUG=gc-friendly,resident-modules    \
+       valgrind --leak-check=full              \
+                --leak-resolution=high         \
+                --num-callers=50               \
+                --suppressions=gtk.suppression \
+                ./aweather                     \
+       2> memcheck.log