]> Pileus Git - grits/blobdiff - src/Makefile.am
Splitting GIS into a shared library, and a lot more
[grits] / src / Makefile.am
index 10c83f051789f8f84f4f32a12b604ed1b45ad131..18976bc36dac8d84f8eb08932cbe2116f5459888 100644 (file)
@@ -1,35 +1,22 @@
-AM_LDFLAGS    = $(RSL_LIBS) $(GTK_LIBS)
-AM_CFLAGS     = -Wall -Werror -Wno-unused --std=gnu99 
-bin_PROGRAMS  = aweather wsr88ddec
+SUBDIRS = gis plugins
 
-BUILT_SOURCES = marshal.c marshal.h
+AM_CFLAGS = -Wall -Werror -Wno-unused --std=gnu99 
 
+bin_PROGRAMS = aweather wsr88ddec
 aweather_SOURCES  = main.c \
-       marshal.c         marshal.h         \
-       aweather-gui.c    aweather-gui.h    \
-       aweather-view.c   aweather-view.h   \
-       aweather-plugin.c aweather-plugin.h \
-       data.c            data.h            \
-       location.c        location.h        \
-       plugin-radar.c    plugin-radar.h    \
-       plugin-radar-colormap.c             \
-       plugin-ridge.c    plugin-ridge.h    \
-       plugin-example.c  plugin-example.h
-aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\"" 
+       aweather-gui.c      aweather-gui.h \
+       aweather-location.c aweather-location.h
+aweather_CPPFLAGS = -DDATADIR="\"$(datadir)\"" $(SOUP_CFLAGS) $(GLIB_CFLAGS) $(GTK_CFLAGS)
+aweather_LDADD    = gis/libgis.la $(SOUP_LIBS) $(GLIB_LIBS) $(GTK_LIBS)
 
 wsr88ddec         = wsr88ddec.c
-wsr88ddec_LDADD   = -lbz2
+wsr88ddec_LDFLAGS = -lbz2
 
 CLEANFILES = gmon.out valgrind.out
 MAINTAINERCLEANFILES = Makefile.in
 
-.list.c:
-       glib-genmarshal --prefix=aweather_cclosure_marshal --body   $< > $@
-.list.h:
-       glib-genmarshal --prefix=aweather_cclosure_marshal --header $< > $@
-
 test: all
-       ./aweather -d 7
+       ./aweather -o -d 7 -s KVNX
 
 gdb: all
        gdb ./aweather